
Microsoft Excel 2010 

Make the switch to Excel 2010



Overview: Switching to Excel 2010

Do you already know how to use 
Microsoft Excel? Are you making the 
switch to Excel 2010 from Excel 2003 or 
earlier? 
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About Excel 
What is a Spreadsheet?

Microsoft Excel is a program that’s used for creating 
spreadsheets. 

So what is a spreadsheet? 

Before personal computers were common, “spreadsheet” referred 
to large sheets of lined paper, which were used by people in 
various businesses to record facts and figures in rows and 
columns, and then make calculations based on the information. 
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What is a Spreadsheet?

When personal computers first began appearing, one of the 
first applications was a program released in 1979 called 
VisiCalc. It was used as a tool for performing spreadsheet style 
calculations that would have been to difficult to do on a 
calculator. The program quickly became so popular that people 
began buying personal computers for their businesses just so 
they could use VisiCalc. 

Since then, many other spreadsheet programs have been 
popular over the years, such as Quattro Pro and Lotus 123. 
Microsoft Excel was first released in 1985 with newer versions 
being released every couple of years. The most recent version 
is (version 14). 

Excel 2010
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How Do Spreadsheets Work?

Computer  spreadsheets  are  based  on  their  old  paper  
formats.  A  spreadsheet  on  a computer uses  rows  and  
columns  to  record  information  such as  text  and  numbers, 
such as the example below. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 5



How Do Spreadsheets Work?
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One major benefit of using computers for spreadsheets is 
that the computer can do a lot of the hard work for you. 
For example, in the table above, the computer could be 
told to automatically work out the summary amounts such 
as total, average, minimum and maximum. 
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How Do Spreadsheets Work?
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A spreadsheet program can also create graphs and other types of charts, 
based on information in your tables. The example below shows a graph 
that was easily created from the table above. 



How Do Spreadsheets Work?
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Spreadsheets are often used for business documents such as invoices 
where numbers and totals are important. A program such as Excel can 
automatically add up totals for a document such as the invoice shown 
below. A document like this could be given a customer to provide 
details of how much money they owe to the business. 



Spreadsheets Contents

The cells in a spreadsheet can contain 3 types of information. Excel 
will treat cells differently depending on the cell contents. 

Text – Any names or labels that are required on the spreadsheet 

Number – All numerical values including dates/times, percentages 
and dollar values 

Formula – Formulas are written in a cell to automatically calculate an 
answer.
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Working with Excel



∗ Quick Access Toolbar -A small bar with icons that can be used to 
quickly access common feature. The icons on this bar can be 
customized. 

∗ Title Bar -Shows the name of the application and the name of the 
currently open file. 

∗ Ribbon -Provides quick access to many of Excel’s features. 

∗ Formula Bar-Used to edit the contents of cells on the spreadsheet . 

∗ Headings -Each column in the spreadsheet has a heading with a 
letter. Each row in the spreadsheet has a heading with a number. 

∗ Sheet Tabs- An Excel file can have more than one sheet. These are 
used for selecting different sheets. 

∗ Status Bar-Shows information based on what you are doing and 
provides quick access to some features. 
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Working with Excel



∗ Opening a file in Excel is done the same way as in 
most other programs. Opening a file can be done in 
one of the following ways: 

∗ Hold down the [Ctrl] key on your keyboard and press 
[O]. 

∗ From the ribbon, select File and then Open 
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Opening an existing File



∗ Select the Open command using one of the above methods. You 
will see the file open dialog as shown below. 
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Opening an existing File



∗ Each file in Excel is referred to as a Workbook. This is 
because each file may contain more than one 
spreadsheet. A new workbook will begin with three 
blank sheets. 

∗ Each sheet contains 1,048,576 rows and 16,384 columns. 
The rectangle areas that make up the rows and columns 
are referred to as cells. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 14

Components of a File



∗ Moving around the workbook can be done with the 
mouse, with the keyboard or with a combination of 
the two. 
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Moving around a Workbook



∗ The sheet in front of you will be made up of numerous cells. You can 
select a particular cell by clicking on it with your mouse. Each cell is 
referred to by its column letter and then its row number. 

∗ For example: in the picture shown below, the cell in column D and 
row 10 is selected. This cell would be referred to as cell D10. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 16

Moving Around With the Mouse



∗ Click on cell C7. 

You will see that the column and row headings are 
both highlighted to let you know which cell you have 
selected. 

∗ Look at the area to the left of the Formula Bar. This area is 
taken up with the Name Box (surrounded by a red circle 
in the example below). Later we will use this area for 
naming areas of your sheet but for now, it will show the 
address of cell(s) that you have selected. 
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Moving Around With the Mouse



∗ Note The scrollbar will change the part of the sheet that you can 
see. It won’t change the part of the sheet you have selected. 
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Moving Around With the Mouse



∗ Press any of the arrow keys on your keyboard to move one cell in that direction. 
∗ Hold down the [Ctrl] key and press [Home]. This will move you to cell A1. 
∗ Press the down arrow ↓ 5 times and press the right arrow → 3 times. You should 

have cell D6 selected. 
∗ Press [Home]. This will move you to column A. 
∗ Hold down [Ctrl] and press the down arrow ↓ to move to the last non-empty cell 

in that direction 
∗ Hold down [Ctrl] and press the right arrow → to move to the last non-empty cell 

in that direction. You should now be on cell D103 (if there are no more non empty 
cells in that direction then it will go all the way to the bottom of the sheet).. 

∗ Press [Ctrl] [Home] again and then practice the additional shortcuts listed below. 
∗ [Page Down] Move down one screen 
∗ [Page Up] Move up one screen 
∗ [Alt] [Page Down] Move right one screen 
∗ [Alt] [Page Up] Move left one screen 
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Moving Around With The Keyboard 



∗ When you are working in a spreadsheet, it is important 
to be able to select cells in the sheet. Some of the more 
common tasks that can be done when cells are selected 
are: 
∗ Format cells (change colours, text sizes etc.) 

∗ Copy and move cells 

∗ Sort information 

∗ Create a graph from the information that’s selected 

Like many things in Excel, selecting cells can be done with 
the mouse or with the keyboard. 
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Selecting Cells 



∗ Move your mouse so that it is positioned over cell D3 

∗ Click and hold down the left mouse button. 

∗ With the button still held down, drag the mouse to 
cell E10 and then release the mouse button. 

∗ All of the cells from D3 to E10 should now be selected. 
Excel refers to this group of cells as D3:E10 
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Selecting by Dragging



∗ Closing a Workbook

∗ Before creating a new workbook, we’ll close the previous one. You can 
have more than one workbook open at the same time, but too many 
files open at once can make your computer run slowly. 

∗ In the top-right corner of the Excel screen you will see 2 buttons with 
crosses on them. The top one will close Excel entirely. The bottom one 
will close the workbook you are working on but Excel will remain open. 
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Creating a New Spreadsheet File 



∗ Click the File tab and then select New from the menu. 

∗ A range of template types will appear 
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Creating a new Workbook 



∗ Make sure Blank workbook is selected and then click the 
Create button to the right. 

∗ A new blank workbook will be created. 

Tip You can quickly create a new workbook by pressing [Ctrl] [N]. 
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Creating a new Workbook 



∗ A file can be saved using one of the methods below. 
∗ Click on the File tab and then click 
∗ Click the Save icon on the Quick Access Toolbar. 

∗ Press [Ctrl] [S]. 
∗ If you haven’t already saved the file, Excel will prompt you 

for a file name and location. If you have already saved the 
file, any of the above methods will simply update the saved 
file with any changes. 

∗ Use one of the above methods to choose the save 
command. Because it is the first time you’ve saved the file, 
you will be asked to specify a filename and a location. 
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Saving a Workbook 



∗ Call the file Grades and choose a suitable location to save it 
in. Excel will add “.xlsx” to the end of the filename. This is 
a file Extension and tells windows that it is a file that 
should be opened in Excel. 

∗ If you have already saved a file and want to give it a 
different name and / or save a copy in a different location, 
you can use the following methods. 

∗ From the File tab select 

∗ Press [F12] 
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Saving a Workbook 



∗ Make sure you are in cell A1. Type your name 
and press [Enter]. 

∗ On Excel’s normal settings, pressing [Enter] will 
not only complete what you are typing in the 
cell, it will also move to the cell below. If cell A2 
hasn’t already been selected for you, then select 
it yourself. 

∗ With cell A2 still selected, type your age and 
press [Enter]. 

∗ With A3 as the selected cell, hold down [Ctrl] 
and press [;]. This should place today’s date in 
the cell. Press [Enter] to complete entry in that 
cell 

Tip If you press [Ctrl] [Shift] [;] the current time 
will be placed in the cell 
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Entering Information in to the Worksheet 



∗ Select cell B1 one and enter the following text (including the spelling 
error). 
∗ Advaned Spreadsheets Class 

∗ To correct the mistake, we’ll need to edit the cell. If you click on the cell 
and begin typing, all of the text in the cell will be deleted. We need to 
change to edit mode so we can edit part of the cell’s contents. There 
are three ways to enter edit mode. 
∗ Double-click on the cell you want to edit 
∗ Press [F2] when the cell you want to edit is selected 
∗ Click in the formula bar below the toolbar icons 
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Editing Cell Contents 



∗ Use one of the above methods to enter Edit mode. A x and 
a       will appear to the left of the formula bar. 

∗ Add a letter C to correct the spelling of the text so that it 
reads Advanced Spreadsheets Class. 

∗ When you have edited the cell contents, press [Enter] or 
click the tick to complete the changes to the cell contents. 
If you want to cancel making changes to the contents of a 
cell, you can press [Esc] or click the cross icon. 
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Editing Cell Contents 



∗ It’s often necessary to copy and move certain parts of 
your spreadsheet. This can be done using any of the 
methods explained below. 

∗ Cut, Copy & Paste

∗ Using the standard Windows copy & paste features is one 
of the most common ways to copy and move information in 
Excel. When you use the cut or copy features in excel, the 
information you had selected is copied to an area of 
Windows known as the clipboard. The copy feature will 
leave the information in its original location so you can 
make a copy. The cut feature will remove it from its original 
location so you can move it. You can then choose where the 
copied, information will go by pasting from the clipboard. 
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Copying and Moving 



∗ To copy the selected information, you can use one of 
the following methods. 
∗ Click the Copy icon on the Ribbon bar. 

∗ Press [Ctrl] [C] 

∗ To cut the selected information, you can use one of the 
following methods. 
∗ Click the Cut icon on the Ribbon bar. 

∗ Press [Ctrl] [X]. 

∗ To paste the selected information from the clipboard, 
you can use one of the following methods. 
∗ Click the Paste icon on the Ribbon bar. 

∗ Press [Ctrl] [V]. 
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Copying and Moving 



∗ Excel has a feature called Auto fill, which enables the 
user to easily copy information over a large range of cells 
at the same time. 

∗ To change to the second sheet, press [Ctrl] [Page Down] 
or click the tab for sheet 2 at the bottom of the screen. 

Tip : You can rename a sheet tab by double clicking on the 
tab, and then entering a new name 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 32

Auto Fill



∗ When the cell is selected, you will see a border 
around the cell that is used for moving cells. In 
the bottom-right corner of that border, is an 
area referred to as the fill handle. If you move 
your mouse over the bottom-right corner, 
your mouse pointer will change to a small 
black cross. 

∗ With your mouse pointer still positioned over 
the fill handle, click and hold the mouse 
button, then drag downwards. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 33

Auto Fill



∗ The spreadsheet should now look similar to the 
example below 
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Auto Fill



∗ Enter the numbers shown below. 
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Creating a table



∗ Although calculations are one of the main uses for spreadsheets, 
Excel can do most of the hard work for you by using a formula. 
When you enter a formula in to a spreadsheet cell, Excel will 
calculate the answer and display the answer in that cell. There are 
a few rules to remember when creating a spreadsheet formula. 

∗ A formula must always begin with an equal sign (they will also 
work with a + or – sign but an equal sign is preferred). As soon as 
you begin a cell with a = Excel will know that you are creating a 
formula. 

∗ A formula will follow the order of operations (BIMDAS). Generally 
if there is more than one part to a formula the calculations will 
work from left to right but… Any part of the formula in brackets 
will be calculated first. Indices will be next. Multiplication and 
division will be next. Addition and subtraction will be calculated 
last. 
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Calculations in Excel 



B Brackets ( ) 
I Indices ^ 
M Multiplication * 
D Division / 
A Addition + 
S Subtraction –

∗ A formula can refer to other cells in the spreadsheet using cell 
references. 

∗ If any part of the formula is referring to text, the text must be 
enclosed in quotation marks “ ”. 

∗ The cells referred to in a formula can’t include the cell the answer will 
be in. This will cause a circular reference error. 
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Calculations in Excel



∗ Create a blank workbook. 

∗ Click in cell A1 and enter the following. 

=5+5 

∗ Press [Enter] to complete the formula. Excel will 
calculate the result. 
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Creating a Simple Formula



∗ Enter the number 5 in cell B1. 

∗ Enter the number 10 in cell B2. 

∗ Enter the following formula in cell B3. 

=b1+b2 

∗ Press [Enter] to complete the formula. Excel will 
calculate the result. 

∗ Change the number in cell B2 to 12 and press [Enter]. 
The result of the formula will be re-calculated (if it 
doesn’t recalculate on its own you can press [F9] to 
force recalculation). 
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Using Cell Referencing



Creation of a formula can be made easier by using the mouse to create cell references. 

∗ Enter the number 10 in cell C1. 

∗ Enter the number 20 in cell C2. 

∗ Click in cell C3 and type a = sign. 

∗ Click on cell C1. The reference for that cell will appear in the formula. 

∗ Type a + sign. 

∗ Click on cell C2. The reference for that cell will appear in the formula. 

∗ Check that the formula reads =C1+C2 and press [Enter]. Your table should look like the 
example below. 

Tip You can make your spreadsheet show formulas instead of answers by clicking the 
Formulas tab on the ribbon and then clicking the button. 
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Using the Mouse for Cell Referencing



∗ Select cell C3 and press [F2] to edit the formula
∗ Notice that the cell references in the formula have become 

coloured. The cells the references refer to have a border 
around them that is the same colour as the reference. These 
coloured borders can be moved as an easy way to edit a 
formula. 

∗ Move your mouse to the edge of the blue border around 
cell C1. 

∗ Drag the border to move it to cell B1. This will change the 
cell reference in the formula. 

∗ Press [Esc] to cancel the changes to in the formula. 
∗ Close the workbook without saving the changes. 
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Editing a Formula



∗ Click on cell B11 and enter the current date by pressing [Ctrl] [;] and then pressing [Enter]. 
∗ Click on cell B12 and enter your date of birth. 
∗ We will create a formula in cell B13 that calculates your age by taking your date of birth away 

from the current date. 
∗ Click in cell B13 and enter the following formula. 

=B11-B12 
∗ The result of the formula will show your age just as it should. Unfortunately, it’s showing you 

your age in days instead of in years which probably isn’t so useful. We can correct this if we 
divide the result by the number of days in a year. 

∗ Edit the formula so that it looks like the one below and press [Enter]. 
=B11-B12/365 

∗ This still won’t give you the correct answer because Excel will calculate division before it will 
calculate subtraction (remember the order of operations). We need to tell Excel to calculate the 
subtraction first and then divide the result by 365. This is where the brackets come in. 

∗ Edit the formula again to look like the one below and press [Enter]. 
=(B11-B12)/365 

∗ That’s more like it. The brackets tell Excel to calculate that part of the formula first. 
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Use of Brackets



∗ Functions are a special kind of formula that can 
simplify complex calculations. The following exercises 
will demonstrate the use of functions. 
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Functions



∗ Make sure the Formulas workbook is still open. 
∗ Click in cell B9. 
∗ Begin your formula with a = sign and then click on cell B2. 
∗ Type a + sign and click on cell B3. 
∗ Complete the formula so that it looks like the one below. 
∗ =B2+B3+B4+B5+B6+B7+B8 
∗ You will get the correct answer, but it’s a long formula. Adding 

together 50 or 100 cells like this would be a tedious process. 
∗ Functions can be used to take the hard work out of many types of 

calculations in Excel. Functions all follow the same format. I.e. = sign, 
name of the function, information to be calculated in brackets. 

∗ =NameOfFunction(information to be calculated) 
∗ There are hundreds of functions built in to Excel and custom functions 

can be created. The most commonly used function is the Sum function. 
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Adding Several Numbers Together 



∗ Click in cell C9. 

∗ Type =sum(C2:C8) and press [Enter]. 

∗ This will tell Excel to add up the sum of all the cells from C2 to 
C8. 

∗ Click in cell D9. 

∗ Type =sum( 

∗ Select cells D2 to D8. 

∗ You can type the right bracket, but if you don’t Excel will put it 
in for you. Press [Enter] to complete the function. It should 
look like the one below. 

=SUM(D2:D8) 
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Sum Function



∗ If you want to add together more than one group of 
cells, you can separate each cell range with a comma. 

E.g. =SUM(C2:C8,E2:E8,G2:G8) 

∗ This would add cells C2 to C8 and E2 to E8 and G2 to 
G8 
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Sum Function



∗ Since the Sum function is used so often, a special tool has 
been provided to make it easy to use. 

∗ Click in cell E9. 
∗ Click the AutoSum icon on the Ribbon bar (It is found on the 

Home and Formulas tabs). 
∗ Excel will create a Sum function referring to the cells above. 

Excel will assume the cells above are the ones to be added 
together. These cells will remain selected in case you would 
rather select a different group of cells. If there are no 
numbers in the cells above, the cells to the left will be used. 
Otherwise the nearest group of cells will be selected. 

∗ Press [Enter] to confirm that the correct cells are selected 
and complete the function. 

∗ The function should look like the one below. 
=SUM(E2:E8) 

∗ You can also use the AutoSum tool by selecting the cells to 
be added first. 
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Using the AutoSum Tool



∗ Select cells F2 to F8. 
∗ Click the AutoSum icon. 
∗ A Sum function will be automatically created based 

on the cells you selected. 
∗ The AutoSum icon can also be used to create other 

common functions such as Average and Count. 
∗ Click in cell G9. 
∗ Click the arrow next to the AutoSum icon. 
∗ A list of common functions will be displayed. 
∗ Click on Average. 
∗ An Average function will be created in the selected 

cell. Notice that it is written the same as a Sum 
function. 

∗ Check that the function reads =AVERAGE(G2:G8) and 
press [Enter] to complete the function. 

∗ Save the changes to the workbook and then close it. 
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Using the AutoSum Tool



∗ Open the Grades workbook 

∗ Add new labels in Column A as shown to the right. 

∗ Click in cell F6. 

∗ Click the AutoSum icon. 

∗ Make sure cells B6 to E6 are selected and press 
[Enter] to complete the function. 
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Using Functions in a Table



∗ Use the fill handle to copy the function down through to cell F16. 

∗ When a formula is copied to other cells, the cell references should change for each cell. 

∗ Click in cell B15. 

∗ Click the arrow next to the AutoSum icon and click on Average. 

∗ Make sure cells B6 to E6 are selected and press [Enter] to complete the function. 

∗ Use the fill handle to copy the formula across to cell F15. 

∗ Click in cell B16. 

∗ Click the arrow next to the AutoSum icon and click on Max. 

∗ Notice that the function has selected all of the cells above including the average cell which we don’t want selected. 

∗ While these cells are still highlighted, select cells B6 to B14 and press [Enter]. The formula in cell B16 should be 
=MAX(B6:B14). 

∗ Use the fill handle to copy the formula across to cell F16. 

∗ Try completing the Lowest mark cells in row 17 yourself by using the Min function. 

∗ Use a Count Numbers function in cell B18 to show the number of students. 

∗ The completed table should look like 
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Using Functions in a Table



∗ If functions can be useful if you want an excel formula 
to select from 2 different answers based on criteria 
you specify. In our grades example, we can use an If 
function to say a student has passed if their mark was 
over 50 and fail if their mark wasn’t over 50. If 
functions have 3 sections with a comma between 
each section as shown below. 

∗ =If(condition to test, answer if condition is true, answer 
if condition is false) 
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Using an If Function



∗ Click in cell G5 and enter the heading Pass/Fail. 
∗ Enter the following If function. 
∗ =If(F6>=50,"Pass","Fail") 
∗ The first part of the formula checks to see if the number in cell F6 

is greater than 50 or equal to 50. The = sign is important. If it was 
left out then someone who scored exactly 50 wouldn’t be 
included. 

∗ The second section says that if this test condition is true, the text 
Pass will be displayed for the answer. Note that where text is used 
in a formula, it must be enclosed in quotation marks. The third 
section specifies the answer (Fail) if the test condition is not true. 

∗ When the If function has been entered, use the fill handle to copy 
the formula down to cell G14. There should be 7 passes and 2 fails. 
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Using an If Function
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Using an If Function



∗ In the previous exercise, you copied formulas to different cells. 
As the formulas were copied, the cells referred to in each 
formula changed to suit the new location. This is because 
formulas normally use relative referencing. 

∗ In the example above, the formula in C1 multiplies A1 by B1. 
When the formula is copied downward, it changes to 
multiplying A2 by B2. This is because Excel is not keeping track 
of exact cell references. It is only seeing the cells in the formula 
are the two cells to the left. When the formula is copied down, 
it is still copying the two cells to the left. 
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Absolute Cell Referencing



∗ Relative references are fine for most formulas but sometimes there are situations 
where you want a formula to refer to a specific cell even when you copy the formula to 
another location. In these situations you need to use absolute references. 

∗ Open the Formulas.xlsx workbook. 

∗ Click in cell I2 and enter 30%. 

∗ Click in cell H2 and enter =G2*I2. 

∗ You should get the correct answer for this cell. 

∗ Use the fill handle to copy this formula down to cell H8. 

∗ All of these cells will be filled with zeros. When the formula is copied down, it will still 
be referring to the cell to the right of the formula, and all of the cells the formula has 
been copied to have nothing to the right. We will need to edit the original formula to 
make sure that it keeps on referring to cell I2, even when the formula is copied to other 
locations. 

∗ Click in cell H2 and press F2 to edit the formula. 

∗ Click on the part of the formula that refers to I2. 

∗ Press [F4]. 
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Absolute Cell Referencing



∗ Dollar signs will appear in the cell reference ($I$2). These dollar signs 
mean that the formula will still refer to column I and row 2 even when it 
is copied to another location. You can type the dollar signs yourself but 
the F4 shortcut will cycle between the different kinds of references. 

∗ I2 Relative reference – row and column references will both change. 
∗ $I2 -Mixed reference – Column reference stays constant, row reference 

will change. 
∗ I$2 -Mixed reference – Row reference stays constant, column reference 

will change. 
∗ $I$2-Absolute reference – Row and column reference will both stay 

constant if the formula is copied to another location. 
∗ Make sure the formula in H2 reads =G2*$I$2 and press [Enter]. 
∗ Use the fill handle to copy the formula down to cell H8. Each formula 

should now be still correctly referring to cell I2. Save and close the 
workbook 
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Absolute Cell Referencing



∗ Lookup functions are a bit like an IF function. They 
allow you to create a formula that will choose from 
several different answers based on information in a 
table. We will use a vertical lookup function to create 
a formula which checks a student’s mark and shows 
what their grade will be. 
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Lookup Functions 



∗ Open the Grades workbook if it is not already open. 

∗ The first thing we will need to do is create the table 
that will contain the grade cut-off points. 

∗ Click in cell K6 and enter a zero. 

∗ Complete the information in cells K6 to L10 as shown 
to the right. 

∗ Click in cell H5 and enter the text Grade. 

∗ Click in cell H6. This is where we want the first grade 
to go. 

∗ Like an If function, a Lookup function has different 
parts. The sections of a lookup function are described 
below. 
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Vertical Lookup



∗ Lookup value -The cell the function is checking, in this case 
the student mark. 

∗ Table array-The cells the answers are coming from - our 
table of grade cut-offs 

∗ Column index -The column in the array that the answer will 
come from. In our case, the function will match the student 
grade with a number in the first column of the array, then it 
will check the second column to find the matching grade, 
so the second column is the column index. 

∗ Range lookup-If the function doesn’t find an exact match in 
the table array, putting true in this section will mean that it 
will use the closest match instead 
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Vertical Lookup



∗ Enter the following formula. =VLOOKUP( 
∗ Click on cell F6 (the cell with the first student’s mark). 
∗ Type a comma to end the first section and then select the grades 

cut-off table (which should be cells K6 to L10. 
∗ Press F4 to make sure this section uses absolute references 

($K$6:$L$10). When we copy the function down for the other 
students we want to make sure it is still correctly referring to the 
cells with the grade cut-off marks. 

∗ Type another comma and then the number 2. 
∗ Type another comma and then type true. 
∗ Type a closing bracket and then press [Enter] to complete the 

formula. The completed formula 
should be =VLOOKUP(F6,$K$6:$L$10,2,TRUE). 

∗ With cell H6 selected, move your mouse over the Fill Handle. 
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Vertical Lookup



∗ Double click on the fill handle. The contents of the cell will be copied down until 
a blank cell is detected to the left. This can be a quick way of using the AutoFill 
function in a table. 

∗ If your lookup table goes horizontally instead of vertically then you can use a 
horizontal lookup function. It works exactly the same except that you type 
Hlookup instead of Vlookup. 

∗ Save and close the file. 
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Vertical Lookup



∗ Formatting a spreadsheet means changing the way it looks to make it 
neater and more attractive. Formatting changes can include 
modifying number styles, text size and colours. Many people format 
their spreadsheet as they go but a lot of time and effort can be saved 
by waiting until the sheet it relatively complete before worrying 
about the formatting. This is because it is a lot easier to format a 
sheet once it already has a good amount of content. 

∗ Formatting a spreadsheet can be done in a number of different 
ways: 
∗ Using AutoFormat 
∗ Using ribbon icons and shortcuts 
∗ Using the format cells dialog box 

∗ The later methods take more time and effort but allow for far greater 
control over the end result. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 62

Formatting a Spreadsheet 



∗ Excel’s AutoFormat feature allows you to choose 
from a number of different table formats and then 
apply the formatting settings to a range of cells you 
specify. When you apply an AutoFormat, it will 
replace any existing formatting on the selected cells. 
You can add your own formatting afterwards though. 
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Using AutoFormat 



∗ Open your Grades workbook if it is not still open. 

∗ Select the cell range A5:H18. This should be the range 
of cells which contains the student results. 

∗ Make sure the Home tab is selected on the Ribbon 
and then click Format as Table. 
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Using AutoFormat on a Table 



∗ Click on one of the table formats in the list. A dialog box 
like the following will appear 

∗ Check that the cell references are correct. Also make 
sure that the My table has headers options is selected. 

∗ Click OK. Excel will format the headings differently from 
the other cells in the table to make them stand out. It 
will also add a small arrow next to each one which can 
be used for sorting and filtering (more on that latter). 
Depending on the format chosen, Excel might also 
assume that rows and columns with formulas are totals 
and format them differently. 

∗ Try some other table formats on your selection. 
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Using AutoFormat on a Table 



∗ Many of the most commonly used formatting options 
can be selected from the Home tab of the ribbon or 
by using keyboard shortcuts. 

∗ Below is a list of the icons available in the ribbon 
along with a description of each. 
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Formatting Using Shortcuts 



∗ Change the font face for the selected cells. E.g. Arial or Comic Sans MS 

∗ Change the text size in the selected cells 

∗ Turns Bold formatting on and off in the selected cells [Ctrl] [B] 

∗ Turns Italic formatting on and off in the selected cells [Ctrl] [I] 

∗ Turns Underline formatting on and off in the selected cells [Ctrl] [U] 

∗ Aligns the contents of each of the selected cells to the left 

∗ Aligns the contents of each of the selected cells to the centre
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Formatting Using Shortcuts 



∗ Aligns the contents of each of the selected cells to the right 

∗ Merges the selected cells and aligns the contents to the centre

∗ Formats the selected cells with the currency style ($#,###.##) 

∗ Formats the selected cells with the percent style (##%) 

∗ Formats the selected cells with the comma style (#,###.##) 

∗ Increases the number of decimal places

∗ Decreases the number of decimal places 
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Formatting Using Shortcuts 



∗ Decreases indent for the selected cells 

∗ Increases indent for the selected cells 

∗ Change the border style around the selected cells 

∗ Change the background colour of the selected cells 

∗ Change the colour of text in the selected cells
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Formatting Using Shortcuts 



∗ Select cells A1:A3. 

∗ Click the Bold formatting icon or press [Ctrl] [B]. 

∗ Note that clicking it again turns the bold formatting off. 

∗ Click the arrow to the right of the Font Size box .
A list of font (text) sizes will appear as shown to the right. 

∗ Click 12. You can also type a number directly in the box and 
press [Enter] if the size you want is not listed. 

Note Font heights are measured in points. 72 points equals one 
inch 
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Formatting Text in Individual Cells 



∗ Click the left align icon. 
∗ Click the arrow to the right of the font select box. A list of fonts will 

appear. 
∗ Click Comic Sans MS in the list to choose this font. You can also type the 

font name in the selection box and press [Enter]. When the list of fonts is 
showing, you can press a letter to move to the first font name starting 
with that letter. They are mostly in alphabetical order, though recently 
used fonts appear at the top of the list. 

∗ Click the arrow next to the Font Colour icon . A list of available font 
colours will appear as shown to the right. 

∗ From the list of colours, choose a colour and click it. You will notice that 
the line on the bottom of the icon will turn to the colour you just 
selected. You can choose that colour again by clicking on the icon itself 
instead of clicking the arrow next to the icon. 

∗ Click the arrow next to the Font Colour icon again. 

Note All of the formatting shortcuts we have used are identical to the ones 
found in Microsoft Word and many other programs. 
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Formatting Text in Individual Cells 



∗ When your formatting is complete, the cells should 
look similar to the example below. 
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Formatting Text in Individual Cells 



∗ It is often important to change the way numbers are presented in a spreadsheet. For 
example, you might want a number that looks like. 

3845 
∗ To appear as 

$3,845.00 
∗ In Excel it is not necessary to type things such as dollar signs yourself since the 

formatting options can place them in for you. Formatting options can easily be 
changed later as well. 

∗ Select the cells that have the grades for the students. These should be cells B6:F18. 
Some of the AutoFormats chosen before may have formatted these numbers as dollar 
amounts which is not appropriate in this instance. 

∗ Click the Comma formatting icon. 
∗ Click the Decrease Decimals icon twice. The numbers should now be back to normal 

with no decimal places. Now we will format the main heading so that it becomes 
centred across several cells. 

∗ Select cells B1:H1. 
∗ Click the icon. 
∗ The selected cells will now be merged in to one with the contents centre aligned. 
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Basic Number Formatting 



∗ Column widths and Row heights can be adjusted by 
going to the menu and selecting Format, Column, 
Width or Format, Row Height. It is usually easier, 
however, to do it using the mouse as demonstrated in 
the following exercise. 
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Column Widths and Row Heights 



∗ Select a cell anywhere within column A. 

∗ On the Ribbon, click the Format icon in the Cells group 
to display the cell format menu. The first options in 
the list are options for adjusting row and column 
height. Many of these options are also available if you 
right click on a row or column header button but there 
are also some quick ways to adjust column width and 
row height. 
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Adjusting Height and Width 



∗ Move your mouse pointer so that it is between the column A and B headings. You mouse 
pointer will change to a double arrow shape. 

∗ Click your mouse button and drag to the right. A caption will appear telling you how wide the 
column will be. 

∗ Keep on dragging until the column width reaches 15.00 (110 pixels). 

∗ You can also resize a column so that it will automatically fit the contents of the column. 

∗ Move your mouse pointer so that it is between the column A and B headings again. 

∗ Double-click to automatically fit the column width to the contents of the column 

∗ Select column B through to column F by dragging across the column headings. 

∗ Follow the steps 3 – 5 in this exercise to change the width of any of the selected columns to 
9.29 (70 pixels). All of the selected columns will become the same width. 

∗ If you use the AutoFit method, then each column will resize to fit its contents. This could mean 
that each column would end up a different size. 
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Adjusting Height and Width 
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Adjusting Height and Width 



∗ Many additional formatting 
options are not shown as 
icons in the Ribbon. These 
additional options can be 
found in the Format Cells 
dialog as shown below. 
There are six tabs along the 
top of the dialog box which 
allow you to go to different 
categories for formatting. 
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Advanced Formatting Options 



∗ Numbers, dollar amounts, percentages, dates and times 
are all treated by Excel as numerical values. As far as Excel 
is concerned, they are all numbers. The only difference is 
the way they are displayed through formatting. In an 
earlier exercise, we used icons on the toolbar so change 
the number format of the main cells in the table. The 
toolbar icons only give a few format choices. The 
Formatting options however, give numerous number 
formatting options and even allow you to create your own 
custom number formats. 
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Number Formats 



∗ Select the cells with the table averages (B15:F15). 
∗ Access the Format Cells dialog box by using one of the following methods. 
∗ Click the small button in the bottom right corner of the Number group on the 

Ribbon (there are also similar buttons in the Font and Alignment groups –
these will take you to different tabs in the same Format Cells dialog box). 

∗ Right-click on the selected cells and choose � Format Cells
∗ Press [Ctrl] [1] to open the Format Cells dialog box. 
∗ Make sure the Number tab is selected. 
∗ From the list of Categories on the left choose Number. 
∗ Set the number of Decimal Places to 2. Note that a sample of the selected 

number format appears at the top. 
∗ Click OK to confirm the change. 
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Changing Number Formats 



∗ Select cell A3. 

∗ Access the Format Cells options as 
shown in the previous exercise. 

∗ Choose Date for the number category. 

∗ Select a date format which includes the 
name of the month rather than the 
number of the month. 

∗ Click Ok when done. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 81

Changing Date Formats 



∗ Select the cells B5:H5. 
∗ Access the Format Cells options. 
∗ Change the Horizontal alignment to Left (Indent). 
∗ Change the Orientation to 45 Degrees (this can be set by entering the 

number in the degrees box shown or by dragging the text line above it to 
the angle you want. 

∗ Click Ok to confirm the settings. 
∗ Select cell B1 (this cell should contain your heading in the merged cells). 
∗ Access the Format Cells options. 
∗ Notice that the Merge Cells option is turned on and the Horizontal 

alignment is set to center because we used the Merge and Center icon 
earlier. Click Cancel to leave these options as they are. 
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Aligning Text 



∗ Select cell B1. 

∗ Access the Format Cells options. 

∗ Select the Font tab. 

∗ Select the following options as 
shown to the right: 

∗ Font Style Bold 

∗ Size 14 

∗ Underline Double 

∗ Colour Dark Blue 

∗ Click OK to confirm the changes. 
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Font Options 



∗ In addition to using the borders icon, there are two 
other ways to format the borders of selected cells. 
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Borders and Shading 



∗ Select cells A1:A3 (the ones with 
your name, age and date of birth). 

∗ Access the Format Cells options and 
click the Border tab. 

∗ Select a line Style from the options 
on the left. 

∗ Choose a line Color from below the 
line styles. 

∗ The rest of the options allow you to 
specify which cell borders will have 
lines. Click the Outline button to 
place borders around the outer 
edge of the selected cells. 

∗ Click Ok to confirm the options. 
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Format Borders Using the Cell 

Format Options 



∗ Another easy way to format borders is by 
drawing them using the Border drawing tools. 

∗ Click the arrow next to the Borders icon. 
∗ At the bottom of the list of border styles, click 

the Draw Border option. 
∗ Before drawing a border you can select a Line 

Style and Line Color from the Borders menu. 
Select a line style and then choose a red colour
for your border. 

∗ Now that the line style has been chosen, drag 
around the cell range K6:L10 to create a border 
around those cells. 

∗ Now draw a vertical line down the middle of 
those cells so that they look like the example to 
the right. 

∗ When you are finished, you can select the Draw 
Border option again from the menu to turn it 
off or you can simply press the [Esc] key. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 86

Drawing Borders 



∗ Select the cells that you have been 
drawing borders around (K6:L10). 

∗ Access the Format Cells options and click 
the Fill tab. 

∗ Click the Patten Style drop-down list . 

∗ When the list of pattern appears, click 
the diagonal stripe pattern. 

∗ Select a light tan for the Pattern Color. 

∗ From the list of colours under 

∗ Background Color click yellow. 

∗ Click OK to confirm the choices. The cells 
should now have a striped pattern like 
the example to the right 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 87

Editing Border Patterns 



∗ Click on a blank cell in your spreadsheet. 
∗ Click the Fill Colour icon to change the background 

colour of that cell. 
∗ Make sure that cell is still selected and press [Del]. 
∗ Pressing delete will remove the contents of a cell 

but won’t affect the formatting in that cell. If you 
want to remove formatting, such as the 
background colour in this cell, you need to use a 
different method. 

∗ From the Ribbon click the CLEAR icon. A list of 
options will appear. 

∗ Select the Clear Formats option. 
∗ All formatting will now be removed from that cell. 
∗ Save the changes to your Grades worksheet 
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Removing Formatting 
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Spreadsheet 



∗ If the built in number formats aren’t quite right for your 
needs, you can create your own custom number formats. 
The examples below demonstrate how this can be done. 

∗ Select the cell with the date (A3). 

∗ Display the Format Cells dialog ( [Ctrl] [1] ) and select the 
Number tab. 

∗ From the Category list select Custom. The custom format 
that is currently in use will be displayed under Type. A list 
of other pre-set custom formats will be shown 
underneath. 
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Custom Number Formats 



∗ The format code might not seem to make a lot of sense but the following pointers 
will help. Also, a sample will show above the Type box to let you know what numbers 
will look like with that format. 

∗ Make sure you have clicked in the Type box and press [F1]. This is the shortcut key for 
Excel’s help. Since you are currently in a custom number format, Excel’s help will 
automatically suggest help topics related to custom number formats. 

∗ Click Create or delete a custom number format to go to that help topic. 
∗ This help topic provides plenty of information about creating custom number 

formats, including explanations of all the symbols you can use in a custom format. 
∗ Click the Close icon to close help (you know how to get to it if you need it later). 
∗ Edit the custom format code so that it looks like ddd d mmmm yy. The table below 

gives a brief explanation of what some of the symbols mean (there are plenty of 
others in Excel’s help). 

∗ Test some of them to create your own custom date format, using the Sample to see 
how your formats look. Look at some of the formats in the custom format list for 
examples. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 91

Custom Number Formats 



∗ Once a table has set up, the information in the table 
can easily be turned in to one of several different 
chart types. These include: 

∗ Column and bar graphs 

∗ Line graphs 

∗ Pie charts 
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Creating Charts 



∗ Select the data to be included in the chart. 
∗ The selection should include table headings. Excel can use 

headings as labels on the chart. 
∗ The selection generally should not include totals. 
∗ Begin the chart wizard which will prompt you for details 

about the chart. 
∗ Customise the completed chart. 
∗ The example below shows the kind of information that 

should be selected before creating a chart, along with a 
sample of the kind of chart that might be crated from the 
selected data. 
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Creating a chart in Excel involves 
following the steps below: 
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Example



∗ Open the Grades file that you have been 
working on previously. We will create a graph 
to show the results for the students each 
term. 

∗ Select the cells A5:E14. Note that this includes 
headings but no totals. 

∗ Select the Insert tab on the Ribbon. 
∗ Click the Column Graph icon. 
∗ From the list of chart types choose the first 3-

D Column option 
∗ A column chart will appear on your sheet. 

When you move your mouse over the chart, 
your mouse will change shape depending on 
what part of the chart it is over. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 95

Creating a Column Graph



∗ Move your mouse over the 
edge of the chart or a 
section of the chart where 
your mouse changes to the 
move shape. 

∗ Drag your chart to the right 
of the cells in column K and 
L. 

∗ Move your mouse to the 
edge of the chart and drag 
to make it larger. 
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Creating a Column Graph



∗ Make sure the chart is 
selected. 

∗ Look at the table the chart 
information is taken from. 
You will notice blue borders 
around the cells the data is 
from and different coloured 
borders around the cells the 
chart labels are taken from 
(the table headings). 
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Changing Chart Data



∗ Drag the bottom corner of the blue 
border upward so that last student is no 
longer included in the selection. The 
chart will automatically update to 
remove that student. 

∗ Drag the border corner back down again 
so that the student is included once 
again. 

∗ Some changes to chart data can’t be 
made easily by shifting the coloured 
borders. If that is the case, then there 
are other ways of doing it. 

∗ From the Chart Tools select the Design 
tab. 

∗ Click the Select Data icon
∗ Check the data in the dialog box and 

click Cancel to close 
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Changing Chart Data



∗ When a chart has been created, you can customise almost 
anything about the way the chart looks. When a chart is 
selected, the Chart Tools tabs will appear on the ribbon. 

∗ These tabs contain icons that can be used to modify the 
chart in several ways. Most parts of a chart can be selected 
and formatted individually as well. 

∗ Select the Layout tab under Chart Tools. 

∗ Click the Chart Title icon. 

∗ From the list that appears select Centered Overlay Title. A 
title will appear on your chart. 
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Modifying a Chart’s Format



∗ Edit the title text so it says Advanced Spreadsheets Class. 

∗ You can use the Home tab to format the font of the title in 
the normal ways (bold, font size etc). You can also use the 
Format tab under Chart Tools to format the whole title 
box with fancy borders, background fills and other 
formatting options. Experiment with the formatting 
options to format your title similar to the example below.

∗ Anything on your chart can be formatted if you select it 
first. 

∗ Click on the chart background and make sure the Design 
tab is still selected. 

∗ Try clicking on some of the chart colour schemes. 

∗ Double-click the chart background. The Format Wall 
options will appear. 
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Modifying a Chart’s Format



∗ From the Fill options choose Picture or 
texture fill. Texture options will appear 
below. 

∗ Click the option and then choose a texture 
you think will suit your chart background. 

∗ Click Close when done. 

∗ Double click the Vertical Axis as shown. 

∗ You can change the Axis data as per your 
needs.
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Modifying a Chart’s Format



∗ Make sure the Design tab is selected under Chart 
Tools. 

∗ Click the Change Chart Type icon. 

∗ Select the last 3-D Column type and then click OK to 
see how the chart will look with that layout. 

∗ Using the same option, try changing the chart to a 
Line chart layout. 
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Changing Chart Type



∗ One of the differences between a pie chart and a normal chart is that a 
pie chart will only show data for one series at a time. In the following 
exercise, we’ll create a pie chart from the year’s data. 

∗ We need to begin by selecting the names of the students (to be used as 
labels) and the data itself. 

∗ Select the cells with the student names including the student heading 
(A5:A14). Since we need to select more than one group of cells we’ll need 
to use the [Ctrl] key. 

∗ Hold down [Ctrl] and select the cells with the year data (F5:F14) 
∗ A5:A14 and F5:F14 should now be selected. 
∗ Click the Insert tab on the ribbon. 
∗ Click the Pie chart icon. 
∗ Choose the Pie in 3-D option. 
∗ Move the pie chart so that it is below your table. 
∗ Click on a pie piece. All the pieces will be selected. 
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Creating a Pie Chart



∗ Click a second time on one of the pieces. That piece alone 
will now be selected. 

∗ Use the format options to change the fill colour for that 
selected piece. The legend next to the chart will update to 
reflect the change in colour. 

∗ Drag the selected piece away from the centre of the chart. 
This allows you to emphasise a certain slice of the chart. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 104

Creating a Pie Chart



∗ Excel has a lot of features that make it perfect for 
working with large lists and manipulating columns of 
data. Using Excel you can sort lists, filter lists and 
subtotal lists. You can also import lists from other 
sources and have the information converted in to 
Excel rows and columns. 
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Working with Lists 



∗ Any area containing no blank rows or columns will be 
recognised by Excel as a list. When you want to 
manipulate a list, Excel will assume that the list 
continues until a blank row or column is found. For 
that reason it is usually not necessary to select an 
entire list. It is normally sufficient to select a single cell 
and let Excel determine the boundaries of the list, 
since it will usually find the whole list fine - as long as 
the list contains no blank rows or columns. In fact, you 
are usually better off if you don’t try to manually select 
the list since you may accidentally miss some of it. 
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Selecting Lists 



∗ Open your Grades file. 

∗ Click on a cell anywhere inside the main table (for example D10). 

∗ Because there are no blank rows or columns within this table, 
Excel will recognise it as being one region. 

∗ Make sure you have the Home tab showing on the Ribbon bar. 

∗ Click the Find & Select icon (it is on the far right end). 

∗ When the menu appears select Go To Special. 

∗ Have a look at the different options that are available (you may 
find some of them useful later). 

∗ Select the Current region option and click OK. The whole table 
should now be selected.

∗ When you are working with lists, Excel will automatically select 
the surrounding region in a similar way. 

Tip When you need to select a region you can also use the keyboard 
shortcut – [Ctrl][*] (or [Ctrl][Shift][8] ). Try it now! 
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Selecting a Region 



∗ Excel will assume that the first row in the list contains column 
headings and will not move them during the sorting process. 

∗ The first step in sorting the list is to click on a cell inside the 
column we want to sort by

∗ Click the Sort & Filter icon at the right end of the Ribbon. 

∗ A list will appear letting you choose how to sort the list. Click on 
the Sort A to Z option to sort the list in alphabetical order, using 
the currently selected column. 

∗ Click the icon again and this time, select the Sort Z to A option 
to sort the list in the opposite order. 

∗ Click in the Position column (column A). 

∗ Click the Sort & Filter icon and then select 

so that the list will once again be sorted by position from 
top to bottom. 
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Manipulating Lists 



∗ Excel provides additional options for sorting a list that 
aren’t available on the Ribbon. 

∗ Click anywhere inside the list. 

∗ Click the Sort & Filter icon and then select

∗ Make sure the My Data has headers option is selected. 

∗ We will add a second sorting level.

∗ Click the Add Level button. 

∗ Click OK to complete the sort.
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Sorting a list using the sort options 



∗ Filtering a list allows you to temporarily hide rows in the list so that 
only certain information will be visible when the list is viewed of 
printed. 

∗ Like sorting, when filtering a list, Excel will automatically select a 
region so it is only necessary to select a single cell within the list. 

∗ Select a cell inside your list. 

∗ Click the Sort & Filter icon. 

∗ When the list appears, click 

∗ Some arrows will appear next to each column heading. These 
arrows can be used to filter the list. Earlier when you were working 
with your Grades spread sheet, you may have noticed filter arrows 
appear automatically when you applied a table AutoFormat. 
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Filtering a List 



∗ Click the arrow to the right of the Artist 
heading. A list of sort options, followed by a 
list of the artists will appear. 

∗ Note Filtering more than one column at a 
time will reduce the number of results you 
will get. 

∗ Type Bruno Mars in the Text Filters box. The 
list below will decrease to only show artists 
that include what you’ve typed. 

∗ Click OK to apply the filter. The table will now 
only show rows where the Artist includes 
Bruno Mars. All other rows will be hidden. 

∗ Click the arrow next to Artist again. 

∗ From the list select                                                          
. The full list will be displayed again 
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Filtering a List 



∗ Click the arrow next to Position. 
∗ Select Number Filters and then select Top 10 

as shown below. If we left the options set to 
top 10 we would have the highest numbers. 
I.e. 91 to 100. We actually want the lowest 
numbers. 

∗ Change the Top option to Bottom as shown 
below. 

∗ Click OK to complete the filter. Note that 
although it is only showing the 10 songs that 
have the lowest position number, they will still 
be sorted in whatever order you last sorted in. 

∗ Select the Data tab from the Ribbon. 
∗ Click the Filter icon. The filter and the arrows 

next to the column headings will be removed. 
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Filtering a List 



∗ Excel can automatically create totals and subtotals 
for information in your list. This is best done if the 
list is already sorted by the column you want it 
grouped by. E.g. in our music charts table, we will 
use subtotals to count the number of songs for 
each artist so make sure your list is still sorted in 
order of artist. 

∗ Click anywhere within the list. Remember Excel 
can automatically select the boundaries of the 
region if you select a single cell within the region. 

∗ Make sure the list is still sorted in order of artist. 
∗ Select the Data tab from the Ribbon. 
∗ Click the Subtotal icon 
∗ Change At each change in to Artist. 
∗ Leave Count for Use function. 
∗ Make sure Artist is the only column ticked under 

Add subtotal to. 
∗ Click OK to add the subtotals. 
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Subtotals 



∗ In addition to adding subtotals, the rows have 
also been grouped by artist. When grouping 
levels have been added to a spreadsheet, you 
will see grouping selector buttons added to the 
left of the sheet. This sheet has three grouping 
levels as shown by the three numbers. 

∗ Click the number 2 button. The list will be 
filtered so you see the subtotals without the 
individual songs. 

∗ Click the number 1 button and you will only see 
the grand total. 

∗ Click the number 3 button and you will see all 
records and totals. 

∗ Next to each subtotal you will also see a – sign 
(shown to the right). 

∗ Click on a – sign and the songs next to it will be 
hidden with only the subtotal remaining. 

∗ The – sign will become a + sign. 
∗ Click the + sign to show the songs again. 
∗ When you no longer want the subtotals you can 

remove them from the subtotals options. 
∗ Click the Subtotal icon on the Ribbon. 
∗ Click the Remove All button. 
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Subtotals 



∗ Creating and editing a list involves a lot of typing. Some people 
are quite comfortable working with large amounts of 
information in a list layout. Others, however, find it a lot easier 
to work with the information with the help of a form. Excel can 
automatically create a data entry form based on the column 
headings in the list. This can be useful if you are editing a table 
with a large number of columns, as this can be a little easier to 
manage in a form. 

Note As with many functions to do with lists, it is important to 
ensure there are no blank rows or columns in your list when using a 
data entry form. 
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Using a form for data entry 



∗ The Excel ribbon bar does not 
contain an icon to display a data 
entry form, but you can easily add 
on to your quick access toolbar. 

∗ Click the arrow at the end of the 
Quick Access Toolbar (in the top left 
of the Excel window). A list of 
common commands will appear. 
Each of these can be added or 
removed from the quick access bar 
buy turning them on or off. 

∗ Select More Commands from the 
bottom of the list. 

∗ Under Choose commands from, 
select All Commands. 
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Using a form for data entry 



∗ A list of Excel’s commands will 
appear in the list. Select in the 
list.

∗ Click Add to add the form 
button to the quick access bar. 

∗ Click OK to close the Options 
dialog. 

∗ A Form icon should now appear 
on the Quick Access Toolbar. 

∗ Select a cell somewhere within 
the list and click the Form icon. 
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Using a form for data entry 



∗ A form appears that allows you to view the information from the list one record at a time. To move to 
the next record, click Find Next, press your ↓ key or click the on the scrollbar. You can also press the 
[Page Down] key to move 10 records at a time. To move to the previous record, click Find Prev, press 
your ↑ key or click the on the scrollbar. You can also press the [Page Up] key to move 10 records at a 
time. 

∗ Move through the records to find the song Airplanes by B.o.B Feat. Hayley Williams. 
∗ Change the artist name to B.O.B. Featuring Hayley Williams. 
∗ Click on Close and this change will be made on the sheet. 
∗ Click on the Form icon again. 
∗ Click Criteria. This allows you to use filters within the form. 
∗ In the Artist field, type david. 
∗ Browse through the records. Only songs by artists with David in the name will show. 
∗ Click Criteria again. 
∗ Click Clear to clear the criteria. 
∗ Browse through the records and they will all be showing again. 
∗ Click New. 
∗ Add the details for a new song (you can make it up). 
∗ Click Close and the song will be added to the bottom of the list, using the formatting from the list. 
∗ Save and close the file. 
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Using a form for data entry 



∗ Files in Microsoft Excel are referred to as Workbooks. This 
is because they can contain more than one sheet. The 
number of sheets a workbook can contain is only limited 
by your computer’s memory. Having several sheets in a 
workbook makes it possible to have several similar tables 
with different data. For example a business wanting to 
keep track of sales data could have a sheet for each month 
of the year and then create a thirteenth sheet that adds up 
the totals from each month. Having the tables on separate 
sheets is a lot neater and easier to work with than having 
several tables all cluttering up the same sheet. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 119

Working with Sheets 



∗ Grouping Sheets-Grouping sheets allows you to edit 
several similar sheets at once. 

∗ Linking Sheets -Create formulas that connect data 
from two or more sheets. 

∗ Sheet Protection-Creating Extra Sheets Restrict your 
worksheet so that only certain parts may be modified. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 120

Working with Sheets 



∗ Make sure Excel is open with a blank workbook ( [Ctrl] [N] for a 
black workbook). By default a new workbook will contain 3 sheets. 

∗ The first sheet in the workbook should be selected. 
∗ Click the New Worksheet icon next to the last sheet tab (or press 

[Shift] [F11] ). A new worksheet (probably titled Sheet4) will be 
added to the workbook. 

∗ Right click on any sheet tab and select Insert. An Insert Dialog will 
appear 

∗ Make sure Worksheet is selected and click OK. Another new 
worksheet will be added. 

∗ Use either of the above methods to create a 6th worksheet. 
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Creating Extra Sheets 



∗ Make sure the first sheet is selected (it doesn’t matter what number is on it 
or which order the numbers are in). 

∗ Right-click on the name of the sheet and select Rename from the shortcut 
menu. 

∗ The name of the sheet will be highlighted so it can be changed. 
∗ Type Jackson for the name of the sheet and then press [Enter] or click away 

from the tab. 
∗ Double-click on the second sheet tab and enter Hawkins as the name. 
∗ Rename the rest of the sheets so they appear as shown below. 

Tip If you want to change the number of sheets that are created with a new 
workbook, select Tools, Options and then select the General tab. You can then 
set the number of sheets a new workbook will have 
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Renaming Sheets 



∗ In the current workbook, there is only a 
small number of sheet tabs. On a 
workbook with more sheets, the tabs may 
not all fit in the bottom area of the screen. 
When that is the case, you can use the 
sheet navigation buttons to view the tabs 
that won’t fit. These are located to the left 
of the sheet tabs
∗ Moves the sheet tabs all the way to the 

left until the first one is visible. 
∗ Moves the sheet tabs to the left one at a 

time. 
∗ Moves the sheet tabs to the right one at a 

time. 
∗ Moves the sheet tabs all the way to the 

right until the last one is visible. 
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Navigating Sheets 



∗ You can also navigate through worksheets 
in other ways.

∗ Right-click on the sheet navigation 
buttons to the left of the sheet tabs. A list 
of sheet names will appear. Click on one of 
the sheet names to move to that sheet. 
When there are too many sheet tabs to fit 
along the bottom, this can be a quick way 
to select sheets. 

∗ If the workbook has too many sheets to 
list, there may be a More Sheets option at 
the bottom of the list. 

∗ Hold down the [Ctrl] key and press [Page 
Down] to move down one sheet at a time. 

∗ Hold down the [Ctrl] key and press [Page 
Up] to move up one sheet at a time. 
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Navigating Sheets 



∗ Click on the first sheet tab to select it. 
∗ Hold down the [Shift] key and click on the fourth sheet to select it. All of the sheets in 

between will become selected. 
∗ Whenever more than one sheet is selected, the word [Group] will appear next to the 

filename in the title bar to indicate that you are working in group mode. You can also use 
the [Ctrl] key to select or deselect sheets. 

∗ Hold down [Ctrl] and click on the last sheet to select it. 
∗ Hold down [Ctrl] and click on one of the already selected sheets to deselect it. 
∗ Click on an unselected sheet without holding down any key to select that sheet alone 

and deselect all others. 
∗ Right click on any sheet tab and choose Select All Sheets to group all sheets. 
∗ Right click on any sheet tab and choose Ungroup Sheets so that only one sheet is 

selected. 

Note When you have more than one sheet grouped, changes you make to cells in one of 
those sheets will affect all of them. Grouping sheets allows you to edit several sheets at 
once we will do in a moment 
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Grouping Sheets 



∗ You can copy existing sheets or change their order in a 
couple of ways. 

∗ Right click on a sheet tab and then select Move or Copy. 
A dialog like the one below will appear. 

∗ This allows you to move sheets within the current 
workbook or to another workbook. You can tick the 
option at the bottom to copy instead of moving. In most 
cases it is quicker and easier to copy and move sheets 
using your mouse. 

∗ Hold down the [Ctrl] key and drag to the right. A + sign 
will appear next to your mouse pointer indicating that 
you are making a copy instead of moving the sheet. 

∗ Release you mouse button to create a copy of the sheet 
in that position. 

∗ Right click on the extra sheet tab and select Delete. 

Note Deleting a sheet cannot be undone. 
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Moving and Copying Sheets 



∗ When you have more than one sheet, it is possible to create a formula that will link several sheets 
together. With our workbook we will create a table that displays averages based on information in 
the other 5 sheets. We could do exactly the same thing using any other calculations such as sum or 
count. 

∗ Create a table like the one below on the Averages sheet
∗ This sheet has no Player Name and Position row. Click in the cell for player height (cell B3). 
∗ Begin creating an average function by entering =AVERAGE( 
∗ Remember that you can use the AutoSum icon on the ribbon to create average functions as well if 

you don’t feel like typing it. 
∗ You can use the mouse to select cells in other sheets for your formula to refer to, the same as you 

would for cells on the same sheet. 
∗ Click on the Jackson sheet tab. The formula will add the sheet name followed by an exclamation mark 

to indicate a sheet reference. =AVERAGE(Jackson!). 
∗ Click the Height cell for Jackson. The formula should now show =AVERAGE(Jackson!B5 
∗ Type a comma to indicate that we will be adding an extra cell to our average function. 
∗ Click the Hawkins sheet tab and then select the height cell for Hawkins. 
∗ Add the height cells for each of the other sheets until the formula looks like the one below and press 

[Enter] to complete the formula. Don’t forget to place a comma after you click on each cell before 
trying to click on the next one. 

∗ =AVERAGE(Jackson!B5, Hawkins!B5, Adams!B5 ,Lyall!B5, Brown!B5) 
∗ The average of all of those cells will now be displayed. Although each of the cells referred to are on 

separate sheets, we can still take advantage of relative referencing to copy the formula so that it 
creates averages for the rest of the statistics. 

∗ With the average cell selected, move your mouse over the fill handle. Double click on the fill handle 
to copy the formula down to the end of the table. 
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Linking Sheets 



∗ You can also link to other Excel workbooks. The 
example below shows how a formula linking to 
another workbook might appear 

∗ File name. If the file is not saved in the same folder 
the full path may be needed. E.g. 
[C:\Files\Functions.xls] 

∗ =[Functions.xls]Functions!$C$9 
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Linking Sheets 



∗ A worksheet can be protected so that only certain cells can be edited. Protecting a 
workbook involves a couple of steps. By default, all cells in a sheet are locked but sheets 
protection is not turned on. First of all you need to specify which cells will be unlocked 
(available for editing). Then you can enable sheet protection. Additionally, you can 
select the hidden option for cells so that any formula used to create the data in that cell 
will not be visible. 

∗ Group all 5 of the player sheets using any method shown earlier. 
∗ Select all of the cells that you want users of the sheet to be able to edit. 
∗ Display the Format Cells dialog using one of the following methods 
∗ From the Home tab on the Ribbon, click the Format icon, then click 
∗ From the Home tab, click the icon in the bottom corner of the Font, Alignment or 

Number group. 
∗ Press [Ctrl] [1]. 
∗ Click on the Protection tab. 
∗ Click the Locked checkbox to clear it so that these cells will be unlocked. 
∗ Click OK. All cells are locked by default but sheet protection is not enabled by default. 

When sheet protection is enabled, only the cells that are not locked can be edited. 

Note If you enable the hidden option, the contents of the cell will be visible on the sheet, 
but not in the formula bar. This means that the results of a formula will be seen on the 
sheet but it will not be possible to see the formula itself while sheet protection is turned on. 
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Worksheet Protection 



∗ Before you can enable sheet protection you will need to 
ungroup the sheets, since you can only protect one sheet at 
a time. 

∗ Ungroup the sheets and make sure one of the player sheets 
is still selected. 

∗ From the Review tab on the Ribbon click the Protect Sheet 
icon. 

∗ The Protect Sheet options allow you to enter a password. If 
you provide a password here, then the sheet can’t be 
unprotected without using that same password. You can 
leave it blank if you want to allow protection to be turned off 
without a password. The other options provide control over 
what can and can’t be modified when the sheet is protected. 

∗ Enter a password if you want to use one or leave it blank, 
then click OK to turn on the sheet protection. 

∗ Try to change one of the cells you unlocked. You’ll be able to 
change it as normal. 

∗ Try to change one of the other cells and a message like the 
one below will appear. 

∗ Click OK to close the message. 
∗ Protect the other player sheets and save the file. 
∗ Worksheet passwords can be up to 255 characters and they 

are case sensitive. Don’t forget your password if you use 
one. 
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Worksheet Protection 



∗ Excel contains numerous tools that are intended to 
meet a wide range of requirements. Some of the 
more specialized tools are useful to only certain types 
of people while others have value for more general 
excel users. 
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Advanced Skills 



∗ In a large spreadsheet, cell referencing and selection may be 
simplified by making use of names. You can assign a unique 
name to an individual cell or to a range of cells. This can make it 
quicker and easier to refer to the cells in charts and functions. 
Additionally, functions that make use of names are easier to 
read. For instance, a formula that says =B4-B5 doesn’t make as 
much sense as a formula that says =Sales-Expenses. 
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Naming Cells 



∗ Create a new workbook in Excel and create a table like the one 
below. 
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Creating Cell Names 



∗ Save the file as Budget. 

∗ Click on Cell A3 which will have the current date. 

∗ Click in the Names box which is to the left of the formula bar. 
Currently it will display the reference of the currently selected cell. 

∗ Click on the Date name. Excel will automatically go to, and select 
that named cell, even if you were on a different sheet. 

Note Whenever you select a cell or range of cells that is named, the 
name will appear in the names box instead of the cell reference 
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Creating Cell Names 



∗ Select the cell range B6:B7 which should contain the cells with the income amounts. 
∗ Click in the Names box, type Income and press [Enter]. 
∗ Select the cell range B11:B20 which should contain the expense figures. 
∗ Click in the Names box, type Expenses and press [Enter]. 
∗ Test the new named ranges by selecting them from the names dropdown list. Each range 

should become selected when you select its range. 
∗ Click in cell D8. This cell will contain the formula to calculate total income. 
∗ Enter the formula =Sum(Income) 
∗ Excel will make use of the range name to add up all of the cells in that range. 
∗ Click in cell B26 which will contain the total expenses. 
∗ Click on the Autosum icon. 
∗ When the Autosum tool completes the function, it will use the range name you have 

created instead of the less meaningful cell references. 
∗ Press [Enter] to complete the function. 
∗ Save the changes to the workbook. 
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Creating Cell Names 



∗ If you have a lot of cells you want to name, it is possible to have the 
names automatically created for you from table headings/labels. 

∗ Select A6:B8. These cells contain the income labels and amounts. 
∗ From the Formulas tab on the Ribbon click the Create from Selection 

icon 
∗ We want the data cells to be named based on the cells in the left 

column so make sure the Left column option is selected and then click 
OK. 

∗ Click in cell B6, B7 or B8. Look in the Names box to see the names that 
have been created. Notice that names with more than one word have 
been created using an underscore. E.g. cell 

∗ B8 will now have the name Total_Income. This is because names cannot 
contain spaces. Names must also begin with a letter. 

∗ Select the cell range B11:B26. This should contain the expenses data 
and labels. 

∗ Click – Create from Selection
∗ Click OK to define names for these cells. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 136

Creating Names Automatically 



∗ We can view, modify or delete the 
names that have already been created 
by using the Name Manager options. 

∗ Make sure the Formulas tab is still 
selected and click the Name Manager 
icon. 

∗ This dialog lists all the names in the 
current workbook. From here you can 
delete names and modify the cells that 
a name refers to. 

∗ Scroll through the list to see 
information about each of the names. 

∗ Click Close to close the dialog without 
making any changes. 
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Creating Names Automatically 



∗ When you are creating a formula you can use names as you 
have already seen. If your workbook has a lot of names, 
however, then it may be difficult to type a particular name 
from memory. You can’t select names from the names box 
since when you are editing a formula; the names box changes 
in to a list of commonly used functions as shown to the right. 
Instead you can insert a name in to a formula. 

∗ Click in cell B23. This is where we will calculate the savings in 
the budget. 

∗ Type an equals sign = to begin a formula. 
∗ From the Formulas tab click– Use In formula . Notice that 

many of the other ribbon options are not available while you 
are editing a cell. A list of names you can use in your formula 
will appear. 

∗ From the list select Total_Income and click OK. The name will 
be inserted in to the formula. 

∗ Type a minus sign. –
∗ Click – Use in Formula
∗ Select Total_Expenses from the list and click OK. 
∗ The formula should appear as =Total_Income-Total_Expenses
∗ Press [Enter] to complete the formula. 
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Pasting Names 



∗ Cell comments can be used to guide a person who is using your 
spreadsheet. They can contain tips, and other information that may 
be helpful. They are indicated by a small red triangle in the corner of 
the cell. When the mouse is moved over the cell, the note will appear 
for the user. Comments can be formatted to match the look of the 
rest of the spreadsheet. 

∗ Select cell with the Electricity amount. 
∗ From the Review tab on the Ribbon click New Comment (You can also 

right click on the cell and select ). A comment will appear next to the 
cell with your name on it. The name is taken from the one that was 
entered when Excel was installed

∗ Enter the text, “This bill is paid every second month” as shown below 
in the comment. 

∗ Click outside the comment to finish editing it. A red mark is visible in 
the top right corner of cell B20. 

∗ Move your mouse over the cell to view the comment. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 139

Cell Comments 



∗ Click the Edit Comment icon on the ribbon (you can also right 
click on the cell and select – Edit Comment

∗ Right click on the border of the comment and select . It is 
important to make sure your mouse is over the comment’s 
border, otherwise you will only be able to format font options. 

∗ Use the Format options to change the background colour of the 
comment under the Colors and Lines tab. 

∗ Make any other formatting changes you like and then click OK 
to close the options. 

∗ Save the changes to the file. 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 140

Cell Comments 



∗ Click the File tab on the Ribbon and then 
click Print. 

∗ From the bottom of the Print options 
select Page Setup. 

∗ On the Sheet tab you will find a Comments 
option. This allows you to choose whether 
or not comments will appear when you 
print your sheet. 
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Cell Comments 



∗ Make sure the Home tab is selected and click Conditional Formatting. 

∗ First we’ll test out some of the Bars, scales and icon sets. 

∗ Select the Data Bars option from the list. 

∗ Move your mouse over some of the data bar options and your 
spreadsheet will show a preview of how that option looks. 

∗ Select the Color Scales option. 

∗ Move your mouse over some of the colour scales options to see how 
they would look. 

∗ Select the Icon Sets option. 

∗ Move your mouse over some of the icon sets options to see how they 
would look. 
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Conditional Formatting 



∗ In addition to the built in conditional format sets, you can create your own 
conditional format rules. 

∗ With the expenses cells still selected, click Conditional Formatting and then 
select – New Rule

∗ Under Select a Rule Type, make sure it is set to Format only cells that contain. 
∗ Change the Edit the Rule Description so that it appears as follows. 

∗ Click the button. Format options will appear. 
∗ Select a dark blue text colour and click OK to return to the Formatting rule options. 
∗ Click OK again to complete the new formatting rule. Since your cells already had dark 

blue text you might not notice a difference until we add additional rules. 

∗ Add three more rules. One to format values from 100 to 399 with green text. 
Another to format values from 50 to 99 with orange text. Another for format 
values below 50 with red text. 

∗ Each of the cells should now be formatted according to their value. 
∗ Try changing the values in some of the cells to see the formatting change. 
∗ Save the changes to the file. 
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Conditional Formatting 



∗ When you have a long table, you might want to keep the headings 
visible when you scroll downward. This is possible with the Freeze 
Panes option. 

∗ When you choose the Freeze Panes option, Excel will freeze any cells 
to the top and left of your current selection so that they don’t scroll. 
If you only want to freeze the top rows then make sure the cell you 
select is in the first column so that there is nothing to the left to 
freeze. 

∗ Click in the first cell under the headings. (A4) 
∗ Select the View tab. 
∗ Click the Freeze Panes icon and then select Freeze Panes. 
∗ A thin line will appear above the cell you have selected. 
∗ Scroll down the sheet and anything above the line will be frozen in 

place. 
∗ Click the Freeze Panes icon again and select Unfreeze Panes 

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 144

Freezing Panes 



∗ If you are creating an Excel spreadsheet that will be used by 
other people it is important to make it as easy to use as 
possible, especially if the eventual users will be people who are 
not skilled at using Excel. Reducing the possibility of errors can 
make a workbook easier to use and this is where Excel’s data 
validation feature can be useful. Data Validation can be used in 
the following ways. 

∗ Restrict the data that can be entered in to certain cells. 

∗ Provide a list of accepted values to assist in data entry. 

∗ Provide prompts to assist a user in data entry. 

∗ Produce meaningful error messages when incorrect data has been 
added. 
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Data Validation 



∗ Select cell B9. This cell contains the duration of the 
show in minutes. Since none of the shows go for longer 
than 200 minutes, we can put in a validation rule which 
restricts the data that can be entered. 

∗ Select the Data tab on the Ribbon. 
∗ Click the Data Validation icon (if you click the top part of 

the icon you won’t need to select from the menu of 
options and will go straight to data validation). A dialog 
box like the one below will appear. 

∗ Change Allow to Whole Number. This will restrict the cell 
so that only whole numbers with no decimals can be 
entered. 

∗ Change Data to less than or equal to. 
∗ When the Maximum box appears, enter 200 in the box 

to set that as the upper limit. In addition to entering a 
number in this box you can also select a cell in your 
workbook which has a suitable value. The options 
should now look like the example above. 
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Adding Data Validation Rules 



∗ The Input Message tab allows us to enter a popup prompt that will appear when the cell is selected. 
Since the cell already has a comment, we’ll leave the Input message for this cell blank. 

∗ Click the Error Alert tab. 

∗ In this tab we can create a custom error message that will appear if the user enters a value not allowed 
under the Validation Criteria. In this case, the error message will appear if a number greater than 200 is 
entered, so we can create an error message appropriate for that situation. 

∗ The Style options determine the type of error message that will appear. For instance, a Stop style error 
message will prevent the entry of invalid data while the other types are only warnings. 

∗ Make sure the Style is set to Stop. 

∗ In the Title enter Invalid Duration.

∗ For the Error Message type, “This cell must contain a number of minutes no greater than 200”. The 
options should look like the example below. 

∗ Click OK to complete the validation rule. 

∗ Type a number greater than 200 in the cell and press [Enter]. Your error message will appear. 

Note We have only created a validation rule for a single cell. If you have several cells that are all going to 
contain similar data, you can select them all so that you can create a validation rule for them all at the same 
time. 
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Adding Data Validation Rules 



∗ Select cell C11. This cell should contain the ticket type. 
∗ Click the Data Validation icon and make sure the Settings tab is showing. 
∗ Change the Allow option to List. 
∗ The Source box will appear. This allows us to provide a list of numbers or 

labels that will be accepted. Anything entered that doesn’t match something 
in our list will produce an error. We can either type in each of the entries 
separated by a comma or select a range of cells which has an appropriate 
value in each cell. Since we already have a suitable range of cells being used 
in the Vlookup function, we can also use it for a data validation list. 

∗ Make sure your cursor is in the source box and make sure you can see the 
Ticket Types table in cells E28:F31 (you can still scroll down when the Data 
Validation options are showing). If you can’t see it, you can click the icon to 
the right of the source box to temporarily hide the dialog box. 

∗ Select cells E28:E31. The cell references will appear in the source box. If you 
hid the Data Validation Dialog in the previous step, click the icon to display it 
again. 
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Create Data Validation Lists 



∗ Select the date in cell B7. 

∗ Select Press [Ctrl] [1] shortcut. 

∗ Make sure the Number tab is selected. 

∗ Select Custom from the Category list. 

∗ Under Type, delete whatever is currently in there. The list below 
that contains several existing custom formats and will also keep 
any that you create so they can be reused later. 

∗ Enter the custom date code 

∗ Click OK to apply the custom format. The date in the cell will now 
take on the new format. 

∗ Select B8, the time cell. 

∗ Create the following custom time format for that cell. 

∗ The format should make the time in the cell look like-7:30 PM 
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Creating Custom Date and Time Formats 



∗ Remember that when you create a custom number format, it is 
possible to create four different formats at once. One for 
positive numbers, one for negative numbers, one for zero 
values and another for text values. Each section in the format is 
separated by a semi colon. 

∗ According to Excel’s online help, if you specify only two 
sections, the first is used for positive numbers and zeros, and 
the second is used for negative numbers. If you specify only one 
section, it is used for all numbers. If you skip a section, include 
the ending semicolon for that section. E.g. 
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Creating Custom Number Formats 



∗ As you saw in the date and time formats, several symbols can be used 
in number formats to represent certain types of formats. Additionally, 
there are a couple of other guidelines to remember. 
∗ Any text that is to appear as part of the format needs to be enclosed in 

quotation marks. 
∗ Any colours that will be included as part of the format need to be 

enclosed in square brackets. [ ] 

∗ Select B9, the cell with the show’s duration. 
∗ Create the following custom format. -- 0 "Minutes" 
∗ The contents of the cell should now show a number (at least one 

digit) followed by the word Minutes. E.g. 120 Minutes 

∗ Select B11, the ticket type amount cell. 
∗ Create the following custom currency format-- $0 
∗ Select cell B14, the ticket price cell and 
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Creating Custom Number Formats 



∗ enter the following custom format. - $#,##0.00;[red]"Error";"0" 

∗ This format will result in positive numbers having a dollar sign 
with two decimal places. For negative numbers, the text Error 
will appear in red (since the total shouldn’t result in a negative 
number). If the value of the cell is zero a 0 will appear. 

∗ Change the number of tickets in B13 to test the format for the 
ticket total

∗ Save your workbook and try these custom formats on a blank 
worksheet and enter data in to the cells to test the formats. 
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Creating Custom Number Formats 
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Creating Custom Number Formats 

Format Suggested test data 

"Remaining balance is" $#,##0.00 Any number 

h:mm AM/PM "-" dd mmmm yyyy now() -- function to calculate current 
date/time 

$0.00;[red]$0.00;"Zero";[green]@ + and – numbers, 0, text 

$* #,##0.00 " Debit";[Red]$* (#,##0.00)" 
Credit" 

+ and – numbers 

"You owe" 0 "dollars" Any number 



∗ The Developer Tab is mainly used for working with Macros. 
Using the Developer tab, you can create, run and edit 
Macros. In addition to this, the developer Tab can also be 
used for working with XML sheets and From Controls. By 
default, the Developer tab will not be shown in the Ribbon 
of any Office application and this becomes difficult when you 
want to work with Macros and Xml Sheets without the 
developer tab. below is a tutorial that will tell you how to 
add the Developer tab into the Ribbon of the Excel 2010 
Application.
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How to Add the Developer Tab in the Ribbon



∗ Click on ‘File’ tab and then on ‘Options’ tab.

∗ In “Excel Options” window that appears on the screen, click on the 
‘Customize Ribbon’ tab.

∗ Now, under ‘Customize the Ribbon’ box, use the drop down arrow to 
find the ‘Main Tabs’ and under the Main Tabs, select the check box 
that is against the ‘Developer’ option.

∗ Finally click on the ‘OK’ button in Excel Options window.

So, this is how you can make the Excel application show the 
Developer tab in the Ribbon.
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How to Add the Developer Tab in the Ribbon



∗ Firstly, insert the “Developer” tab in the ribbon of the Excel 
Application.

∗ Now, on the “Developer” tab, under the ‘Code’ category, click on the 
‘Record Macro’ icon.
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Creating a Macro



∗ A ‘Record Macro’ dialogue box appears on the screen. in this dialogue 
box, give a name for the Macro, specify a short cut key to run the 
macro later, location where you want store the macro and a brief 
description about the macro and finally click on the ‘OK’ button.
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Creating a Macro



∗ Now, do the necessary tasks that you want on the Excel sheet 
and the tasks that you perform will be recorded by the Macro

∗ Once you are finished with performing all the tasks, click on the 
‘Stop Recording’ icon that you find on the ‘Developer’ tab 
under the ‘Code’ category
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Creating a Macro



∗ To Run a Macro that you created above, click on the ‘Macros’ 
icon that you find on the ‘Developer’ tab under the ‘Code’ 
category.

∗ Now a ‘Macro’ dialogue box appears on the screen which 
contains a list of Macros in it.

∗ Select the Macro that you created from the List and click on 
the ‘Run’ tab.

∗ Now the Macro will be run in the worksheet. You can have the 
Macro run in any worksheet of the Workbook.

∗ You can also run the created Macro by using the Shortcut key 
that you specified while creating the Macro.
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Run a Macro



∗ Excel provides the user with a large collection of ready-made functions, 
more than enough to satisfy the average user. Many more can be added 
by installing the various add-ins that are available.

∗ Most calculations can be achieved with what is provided, but it isn't 
long before you find yourself wishing that there was a function that did 
a particular job, and you can't find anything suitable in the list. You need 
a UDF.

∗ A UDF (User Defined Function) is simply a function that you create 
yourself with VBA. UDFs are often called "Custom Functions". A UDF can 
remain in a code module attached to a workbook, in which case it will 
always be available when that workbook is open. Alternatively you can 
create your own add-in containing one or more functions that you can 
install into Excel just like a commercial add-in.

∗ UDFs can be accessed by code modules too. Often UDFs are created by 
developers to work solely within the code of a VBA procedure and the 
user is never aware of their existence.
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About User Defined Functions



∗ Suppose you need a function to calculate the area of a rectangle. 
You look through Excel's collection of functions, but there isn't 
one suitable. This is the calculation to be done:

∗ AREA = LENGTH x WIDTH

∗ Open a new workbook and then open the Visual Basic Editor 
(Developer> Source or ALT+F11).
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A Function to Calculate the Area of a Rectangle



∗ You will need a module in which to write your function 
so choose Insert > Module. Into the empty module 
type: Function Area and press ENTER. The Visual Basic 
Editor completes the line for you and adds an End 
Function line as if you were creating a subroutine.

Function Area() 

End Function
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A Function to Calculate the Area of a Rectangle



∗ Place your cursor between the brackets after "Area". If you ever 
wondered what the brackets are for, you are about to find out! 
We are going to specify the "arguments" that our function will 
take (an argument is a piece of information needed to do the 
calculation). Type Length as double, Width as double and click in 
the empty line underneath. Note that as you type, a scroll box 
pops-up listing all the things appropriate to what you are typing.
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A Function to Calculate the Area of a Rectangle



∗ This feature is called Auto List Members. If it doesn't appear 
either it is switched off (turn it on at Tools > Options > Editor) or 
you might have made a typing error earlier. It is a very useful 
check on your syntax. Find the item you need and double-click it 
to insert it into your code. You can ignore it and just type if you 
want. Your code now looks like this...

Function Area(Length As Double, Width As Double) 

End Function
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A Function to Calculate the Area of a Rectangle



∗ Declaring the data type of the arguments is not obligatory but makes 
sense. You could have typed Length, Width and left it as that, but 
warning Excel what data type to expect helps your code run more 
quickly and picks up errors in input. The double data type refers to 
number (which can be very large) and allows fractions.

∗ Now for the calculation itself. In the empty line first press the TAB key to 
indent your code (making it easier to read) and type Area = Length * 
Width. Here's the completed code...

Function Area(Length As Double, Width As Double) 

Area = Length * Width 

End Function
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A Function to Calculate the Area of a Rectangle



∗ You can test your function right away. Switch to the Excel 
window and enter figures for Length and Width in separate cells. 
In a third cell enter your function as if it were one of the built-in 
ones. In this example cell A1 contains the length (17) and cell B1 
the width (6.5). In C1 I typed =area(A1,B1) and the new function 
calculated the area (110.5)...
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A Function to Calculate the Area of a Rectangle



∗ Sometimes, a function's arguments can be optional. In this 
example we could make the Width argument optional. Supposing 
the rectangle happens to be a square with Length and Width 
equal. To save the user having to enter two arguments we could 
let them enter just the Length and have the function use that 
value twice (i.e. multiply Length x Length). So the function knows 
when it can do this we must include an IF Statement to help it 
decide.
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A Function to Calculate the Area of a Rectangle



∗ Change the code so that it looks like this...

Function Area(Length As Double, Optional Width As Variant) 
If IsMissing(Width) Then 

Area = Length * Length 
Else 

Area = Length * Width 
End If 

End Function

Note that the data type for Width has been changed to Variant to allow for null 
values. The function now allows the user to enter just one argument e.g. 
=area(A1). The IF Statement in the function checks to see if the Width argument 
has been supplied and calculates accordingly...
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A Function to Calculate the Area of a Rectangle



∗ The calculation is the number of miles the car has travelled since 
the last fill-up divided by the number of gallons of fuel used...

∗ MPG = (MILES THIS FILL - MILES LAST FILL) / GALLONS OF FUEL

∗ but because the fuel comes in litres and there are 4.546 litres in a 
gallon..

∗ MPG = (MILES THIS FILL - MILES LAST FILL) / LITRES OF FUEL x 
4.546
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A Function to Calculate Fuel Consumption



∗ The following sample macro searches a single list in the range 
A1:A100 and deletes all duplicate items in the list. This macro 
requires that you do not have empty cells in the list range. If 
your list does contain empty cells, sort the data in ascending 
order so that the empty cells are all at the end of your list.
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Delete duplicate items in a single list



Sub DelDups_OneList()

Dim iListCount As Integer

Dim iCtr As Integer

' Turn off screen updating to speed up macro.

Application.ScreenUpdating = False

' Get count of records to search through.

iListCount = Sheets("Sheet1").Range("A1:A100").Rows.Count

Sheets("Sheet1").Range("A1").Select

' Loop until end of records.

Do Until ActiveCell = ""

' Loop through records.

For iCtr = 1 To iListCount

' Don't compare against yourself.

' To specify a different column, change 1 to the column number.

If ActiveCell.Row <> Sheets("Sheet1").Cells(iCtr, 1).Row Then

' Do comparison of next record.

If ActiveCell.Value = Sheets("Sheet1").Cells(iCtr, 1).Value Then

' If match is true then delete row.

Sheets("Sheet1").Cells(iCtr, 1).Delete xlShiftUp

' Increment counter to account for deleted row.

iCtr = iCtr + 1

End If

End If

Next iCtr

' Go to next record.

ActiveCell.Offset(1, 0).Select

Loop

Application.ScreenUpdating = True

MsgBox "Done!"

End Sub
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∗ The following sample macro compares one (master) list against 
another list, and deletes duplicate items in the second list that 
are also in the master list. The first list is on Sheet1 in the range 
A1:A10. The second list is on Sheet2 in the range A1:A100. To use 
the macro, select either sheet, and then run the macro.
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Compare two lists and delete 

duplicate items



∗ Sub DelDups_TwoLists()
∗ Dim iListCount As Integer
∗ Dim iCtr As Integer

∗ ' Turn off screen updating to speed up macro.
∗ Application.ScreenUpdating = False

∗ ' Get count of records to search through (list that will be deleted).
∗ iListCount = Sheets("sheet2").Range("A1:A100").Rows.Count

∗ ' Loop through the "master" list.
∗ For Each x In Sheets("Sheet1").Range("A1:A100")
∗ ' Loop through all records in the second list.
∗ For iCtr = 1 To iListCount
∗ ' Do comparison of next record.
∗ ' To specify a different column, change 1 to the column number.
∗ If x.Value = Sheets("Sheet2").Cells(iCtr, 1).Value Then
∗ ' If match is true then delete row.
∗ Sheets("Sheet2").Cells(iCtr, 1).Delete xlShiftUp
∗ ' Increment counter to account for deleted row.
∗ iCtr = iCtr + 1
∗ End If
∗ Next iCtr
∗ Next
∗ Application.ScreenUpdating = True
∗ MsgBox "Done!"
∗ End Sub
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∗ An Excel pivot table is a versatile reporting tool that makes it 
easy to extract information from a large table of data without 
the use of formulas.

∗ A pivot table is extremely user friendly in that by moving, or 
pivoting, fields of data from one location to another using drag 
and drop we can look at the same data in a number of different 
ways.
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Pivot Table 
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Pivot Table 



∗ Drag select cells A2 to D12 to highlight 
them.

∗ Click on the Insert tab of the ribbon.
∗ Click on the down arrow at the bottom of 

Pivot Table button to open the drop down 
list.

∗ Click on Pivot Table in the list to open the 
Create Pivot Table dialog box.

∗ By pre-selecting the data range A2 to F12, 
the Table/Range line in the dialog box 
should be filled in for us.

∗ Choose Existing Worksheet for the 
location of the pivot table.

∗ Click on the Location line in the dialog box.
∗ Click on cell D16 in the worksheet to enter 

that cell reference into the location line.
∗ Click OK. 
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Pivot Table 



∗ A blank pivot table should appear on the 
worksheet with the top left corner of the 
pivot table in cell D16.

∗ The Pivot Table Field List panel should 
open on the right hand side of the Excel 
window.

∗ At the top of the Pivot Table Field List
panel are the field names ( column 
headings ) from our data table. The data 
areas at the bottom of the panel are 
linked to the pivot table.
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Pivot Table 



∗ You have to select the field names which are available two 
choices when it comes to adding data to the Pivot Table: 

∗ Drag the field names from the Pivot Table Field List panel and drop 
them on the Pivot Table in the worksheet.

∗ Drag the field names to the bottom of the Pivot Table Field List
panel and drop them in the data areas.

∗ The data areas in the Pivot Table Field List panel are linked to 
corresponding areas of the pivot table. As you add the field 
names to the data areas, your data is added to the pivot table.

Nitin Dawar, Delhi University Computer Centre, nitin@ducc.du.ac.in 178

Pivot Table 



∗ Home Move to column A in a sheet 
∗ Ctrl Home Move to cell A1 in a sheet 
∗ Ctrl and arrow Move to the last non blank cell in that direction 
∗ Page Down Move one screen down 
∗ Page Up Move one screen up 
∗ Alt Page Down Move one screen to the right 
∗ Alt Page Up Move one screen to the left 
∗ Ctrl A Select all the non-blank cells in the sheet 
∗ Ctrl Spacebar Select a whole column 
∗ Alt F4 Close Excel 
∗ Ctrl F4 or Ctrl W Close the current file 
∗ Ctrl N Create a new workbook 
∗ Ctrl O Open a workbook 
∗ Ctrl S Save the current workbook 
∗ F12 Save the current workbook with a different name/location 
∗ Ctrl F6 Switch between open workbooks 
∗ Ctrl ; Enter the current date 
∗ Ctrl Shift ; Enter the current time 
∗ F2 Edit the currently selected cell 
∗ Ctrl C Copy selected cells 
∗ Ctrl X Cut selected cells 
∗ Ctrl V Paste cells that have been cut or copied 
∗ Home Move to column A in a sheet 
∗ F9 Recalculate formulas 
∗ F4 Change between absolute, relative or mixed references in a formula
∗ Ctrl 1 Open the Format Cells dialog 
∗ F1 Display Excel help 
∗
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