Notes 1 for Class 5
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IMPORTING DATA FROM OTHER SOURCES – 
1. Factors affecting the importing of data - The process and outcome of importing data from some sources into a word document depends on following factors
a. Type of source document– This refers to whether the source is a text document, word document, pdf, excel sheet, presentation, web page or something else. In case of some sources, the source data is not imported in exactly the same manner as expected. 
b. Amount of source data – Whether all the content of a source is imported or source is imported partially, i.e. some part of the content is imported. 
c. Types of source data – Whether the data is unformatted text, formatted text, picture, chart, excel sheet, bitmap image, open document content etc. 
d. Forms of the imported data – An imported data can take many forms and the method of importing will depend on which of type of imported data does a user want/need. The imported data can assume the following types:
i. As visible content or as an icon – Normally the imported content is visible and runs along with the other contents of the destination document. But if the source content is imported as an icon, the imported content is not visible; instead a user sees an icon which needs to be clicked in order to see the imported content.
ii. As original content or as modified content – Normally original content keep all the features (e.g. formatting etc.) of the source content, but if required, the imported content can be different form the source content in terms of text, format, picture etc. For example a user can get the imported text only to contain the unformatted text or original source as a picture only.
iii. As normal content or as an object of source application– The original content can be imported either as a normal content where the imported content becomes the content of the destination application or as an object of source application e.g. importing a spreadsheet of excel in a word file as an object of excel application. If content is imported as an object of source application, it is opened with its source application when user wants to modify the imported content. However this option works only when source and destination documents support OLE technology. 
OLE which stands for Object Linking and Embedding, is a Microsoft technology that helps in sharing data between two applications e.g. sharing an excel chart in word document. OLE ensures that the parent application of an object is opened user wants to modify it. For example, if an excel chat is imported in a word document, OLE will open excel application when user wants to modify the imported chat in word.  
Technically, OLE technology enables the target application (in which an object is embedded) to pass on (hand over) the embedded object for necessary changes and receive back the object after changes.
iv. As embedded object (Non-linked object) or as linked object – OLE offers two forms of importing objects – as embedded object or as linked object. If some source data is imported as an embedded object, a copy of the source content is inserted in the destination document. The imported content has no connection with the original source document. In this case if the source content is changed, it does not automatically changes/updates the imported content. However if some source data is imported as a linked object, it is linked to its original source. If the source content is changed, the imported content also gets changed/updated automatically.  
2. Methods of importing data into MS Word – There are various methods available to import data from different sources into a word document. The methods are of the following categories, each of which as their own nuances to give desired outcome : 
a. Copy + Paste; 
b. Copy + Paste Special
c. Insert  + Object
d. Insert + Object + Text from File
e. Insert + Quick Parts + Fields 
An appropriate method can be selected depending what form of outcome is desired.
a. Copy + Paste – imports the source data with its source formatting. 
b. Copy + Paste (Keep Source Theme) – imports the source data with its own formatting along with pictures, tables etc. 
c. Copy + Paste (Merge Formatting) – merges the source text with formatting available surround the place of import.
d. Copy + Paste (As Picture) – converts the source data into a picture
e. Copy + Paste Special (Microsoft Word Document Object) – imports the source data as a word data such that the imported data remains an independent word document which can be double clicked and opened in a separate document.
f. Copy + Paste Special (Formatted RTF) – converts the imported data into a Rich Text Format (However the difference between word data and Rich Text Data is not obvious)
g. Copy + Paste Special (Unformatted Text) – converts the imported data into text. Therefore, even if the source data contains text, pictures, tables etc. this process extracts only the text part of the source data. The imported unformatted text takes the formatting applicable at the place surrounding the point of import.
h. Copy + Paste Special (Picture) – converts the imported text as picture
i. Copy + Paste Special (HTML Format) – converts the imported text into html content which is used for creating web pages
j. Copy + Paste Special (Unformatted Unicode Text) – Like Unformatted Text, this method extracts unformatted Unicode text. 
k. Copy + Paste Special as a link – This method imports the data in a separate object whose link is inserted in the target document. A use can always see the content of the linked imported text by double clicking on it. 
l. Insert Object and create the object simultaneously – This method allows a user to import some content which does not exists already and is created during the process. For example, if a user imports a bit map image, MS Word provides bit map application for creating a new bit map image which is later inserted in the document. Such objects are not stored on the disc as a separate file. It inserts the whole data of the source.
m. Insert Object from an already existing file – Unlike the previous option, the imported file already exists in the file system which is inserted in the current document. Again the whole of the source document/data is inserted. In such a case the inserted text becomes a copy of the source data.
n. Inserting Object as link – This option does the same as the previous one except that the inserted data is a linked copy of the source data so that the inserted data is changed if the source data is changed. 
o. Insert Text from file – This method inserts the whole of an external file. If the external file is another word document, it brings in all the pages. But if the source document is some other file like pdf, excel, power point etc., we have seen it to import only first page or first slid and not the remaining ones in the usual case. 
p. Insert Text from file as link – Similar to the previous case, the imported contents of the source document exists as a lined copy such that any change is the source document are reflected in the target document as well.
EXPORTING WORD FILES – 
An MS Word document can be exported (converted and/or saved) into different files so that it may be used for other purposes as well. Some of the most frequently used export options are as follows. 
a. Exporting as word files of other versions – A word file created with a particular MS Word version can be saved in other versions so as to be usable with MS Word of other versions. This provides a portability of the document across different versions of MS Word. 
b. As text file – Sometimes, we only want to get the text part of the document. In such cases, a word file can be saved as a text file. The exported file can later be opened with apps like Notepad, Notepad ++ etc. 
c. As pdf – Sometimes a use wants to export only a readable and printable version of the document in place of the editable MW Word document. In such as case, the MS Word document can be exported as a pdf (printable document format) which shows the contents exactly as how they will be printed. Sometimes, MS Word files is converted into a pdf to get rid of its macros (if there are).
d. As web document – Sometimes a user wants convert a document into a web page such that it may be published on the web. For this reason, MS word provides a facility to save the document as a web page. For this purpose there are three kinds of web page conversion provided by MS Word – 1) Single File Web page, 2) Web page and 3) Web page filtered. A single file web page is stored in one file only while saving the document as a web page converts the document as a collection of many web based files. However the web page filtered is used ……(TBD) 
MACROS IN WORD
Macros refer to programs that can be used in a word document to achieve some automation task. The macros of a word document are stored in the same word file and can be executed as and when required. A macro like a program is a set of instructions. When a macro executes, all the instructions of the macro get executed. If a user has some predefined defined set of instructions which are to be executed together one or more than one times, macros can be created for a quick execution of those instructions. 
1. Creating macros – Macros can be prepared in the following two methods
a. Recording macros – As macros are frequently used for bundling many instructions together, a macro can be created by recording the sequence of commands issued by a user manually. Use View>Macro>Record Macro   
b. Writing macros – In case a user is aware of the VBA language, she can also write macro instruction on its own to create the macro program. Use View > Macro > View Macro > Create
2. Playing/Executing macros – Once a macro has been written and save with MS word, it can be executed, i.e., user can run the macro. Use View > Macro > View Macro > Run
Security Issues with Macro – A macro can be a security threat, if the instructions that it executes try to do some undesired task, e.g., deleting the file content. A macro that contains malicious instructions and also infects other files is called a macro virus. A macro virus contained in A MS file (word, excel etc.) usually gets spread when such files are sent as email attachments and opened by the receiver. 
SECURITY FOR DOCUMENTS – 
A MS word document may require protection from being copied, edited, printed, malicious embedded objects and malicious macros. 
Securing Documents – A document can be secured depending on what threat it is being secured from. Following are the main methods for protecting a MS word document.
i. Securing document through document password & access restrictions (Password Security) – A document can be secured form unwanted editing by protecting the document by a password. However, the security against particular unwanted tasks of copying or printing is achieved by restricting the access to the document. A person can perform the restricted operations only after unlocking the document using the correct password. See File>Info>Protect Document> for setting password>Encrypt with password for setting up the password. 
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Caution: MS Word suggests that a password once set cannot be recovered if forgotten. It is therefore recommended to use the password on the documents only when we can remember or safely keep it somewhere. 

ii. OLE Security – In the past OLE had shown a Remote Code Execution vulnerability due to which a user if is successfully able to execute any code on a compromised computer. To protect user from OLE code, it is recommended that user disables the running of active content in the browser setting. The user is also advised not to open any lined object which comes from untrusted source. A user can also work in a safe mode in order to avoid any malicious code from running.  
iii. Macro security (Checking and removing macros) – One can check if there are any macros in a MS Word or Excel sheet by going to view>macros>view macros link. This will show the list of macros present in the document. Security from the macros can be obtained by either not letting a macro execute itself or delete the macros from the file. One can also copy all the contents of a document from original document to a new document and delete the original document.
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One can also use antivirus programs that clean macro viruses as well.
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